app_uwsgi.spec 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # -*- mode: python ; coding: utf-8 -*-
  2. uWSGI_EXECUTABLE = '/usr/local/bin/uwsgi'
  3. block_cipher = None
  4. a = Analysis(
  5. ['app_uwsgi.py'],
  6. pathex=[],
  7. binaries=[(uWSGI_EXECUTABLE, '.')],
  8. datas=[('./config.yml', './'), ('./cache/data/*.csv', './cache/data/'), ('./var', './var'), ('./ssl', './ssl'), ('app.ini', '.')],
  9. hiddenimports=[],
  10. hookspath=[],
  11. hooksconfig={},
  12. runtime_hooks=[],
  13. excludes=[],
  14. win_no_prefer_redirects=False,
  15. win_private_assemblies=False,
  16. cipher=block_cipher,
  17. noarchive=False,
  18. )
  19. for bi in a.binaries:
  20. if bi[0] == uWSGI_EXECUTABLE:
  21. bi[1] = 'uwsgi'
  22. pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
  23. exe = EXE(
  24. pyz,
  25. a.scripts,
  26. [],
  27. exclude_binaries=True,
  28. name='app_uwsgi',
  29. debug=False,
  30. bootloader_ignore_signals=False,
  31. strip=False,
  32. upx=True,
  33. console=True,
  34. disable_windowed_traceback=False,
  35. argv_emulation=False,
  36. target_arch=None,
  37. codesign_identity=None,
  38. entitlements_file=None,
  39. )
  40. # exe.files.append(uWSGI_EXECUTABLE)
  41. coll = COLLECT(
  42. exe,
  43. a.binaries,
  44. a.zipfiles,
  45. a.datas,
  46. strip=False,
  47. upx=True,
  48. upx_exclude=[],
  49. name='app_uwsgi',
  50. )